macros

List Of Macros:

  • %PROCSTATUS(processName) - returns ON if process is running, OFF else

    example: %PROCSTATUS("opera.exe") will return ON if Opera is running
  • %KILLPROC(processName) - kills the process

    example: %KILLPROC("opera.exe")
  • %FILESIZE(filename,format) - returns size of specified file, format is one of the following:

    M - size in MegaBytes
    K - size in KiloBytes
    B - size in Bytes

    example: %FILESIZE("c:\windows\explorer.exe","k") will return 977
  • %OWNIP - returns your ip address if u're online, OFFLINE else
  • %COPYFILE(source,destination,option) - Copies file source to destination , option specifies how this operation is to proceed if a file of the same name as that specified by destination already exists. If this parameter is 1 and the new file already exists, the macro fails. If this parameter is 0 and the new file already exists, the macro overwrites the existing file and succeeds.

    example: %COPYFILE("c:\windows\explorer.exe","c:\explorer.exe","1")
  • %DELETEFILE(filename) - Deletes file filename

    example: %DELETEFILE("c:\temp.txt")
  • %DELETEFILES(wildcard) - Deletes all files specified with wildcard

    example: %DELETEFILES("c:\windows\temp\*.txt")
  • %MD5(string) - calculates MD5 hash of string
  • %WTITLEE(word) - returns title of window ending with word

    example: %WTITLEE("Explorer") will return "about:blank - Microsoft Internet Explorer" (if Internet Explorer is open with a blank page)
  • %WTITLES(word) - returns title of window starting with word

    example: %WTITLES("ACDSee") will return "ACDSee 6.0 - My Pictures" (if "My Pictures" folder is open in ACDSee )
  • %WTITLEALL - returns titles of all windows
  • %WTITLEREGEXP(regexp) - returns title of window matching regexp regular expression

    example: %WTITLEREGEXP("[0-9]+.*Winamp") will return Winamp window title
    (like "50. Sepultura - Roots, bloody, roots - Winamp" :] )
  • %INETTIME - internet time in beats(1000 beats=1 day)
  • %NUM_LOCK_ON
    %NUM_LOCK_OFF
    %CAPS_LOCK_ON
    %CAPS_LOCK_OFF
    %SCROLL_LOCK_ON
    %SCROLL_LOCK_OFF

    - toggles NumLock(CapsLock ,ScrollLock) on/off
  • %NUMLOCK_IS_ON
    %CAPSLOCK_IS_ON
    %SCROLLLOCK_IS_ON

    - returns ON(OFF) if corresponding "lock" is on(off)
  • %GETINIVALUE(filename,section,key) - retrieves specified key value from .ini file

    example: %GETINIVALUE("c:\boot.ini","boot loader","timeout") will return the timeout key value from boot.ini file's [boot loader] section , e.g. 10
  • %SETINIVALUE(filename,section,key,value) - set specified key value in .ini file to specified value

    example: %SETINIVALUE("c:\boot.ini","boot loader","timeout","30") will set the timeout key value in boot.ini file's [boot loader] section to 30

    these 2 macros can be used to store %_variables in ini file and retrieve them later
  • %FIGLET(text,font_name) - returns text using specified figlet(Frank, Ian & Glenn's Letters) font. font_name - is the name of corresponding flf-file from "fonts" folder.

    example: %FIGLET("hello","smslant") will return the word "hello" using "smslant" font:
       __       ____
  / /  ___ / / /__
 / _ \/ -_) / / _ \
/_//_/\__/_/_/\___/
    18 figlet fonts are included, additional fonts can be installed by copying them to "fonts" folder.
    More fonts(over 400) can be downloaded from ftp://ftp.figlet.org/pub/figlet/fonts/
  • %WINAMP_GET("parameter") - returns corresponding information about winamp.
    Works with     Winamp 2(5),Quintessential Player,Apollo,MediaMonkey.To make it work with iTunes player download plugin for iTunes.
    parameter can be one of the following
    • status - OFF,STOPPED,PLAYING ,PAUSED
    • title - current playing song title
    • playlist_length - number of songs in playlist
    • playlist_pos - playlist position(current playing song number)
    • bitrate - current playing song's bitrate
    • samplerate - current playing song's samplerate
    • channels - current playing song's channels number
    • track_length - the track length, in seconds
    • position -the position in milliseconds of the current track

    example: %IF:%WINAMP_GET(status)=PLAYING:"now playing song %WINAMP_GET(playlist_pos) of %WINAMP_GET(playlist_length)":"Winamp is stopped"
  • %WINAMP_CMD("command") - sends winamp(Quintessential Player,Apollo) the specified command.
    Works with Winamp 2(5),Quintessential Player,Apollo,MediaMonkey. Player must be running.

    command can be one of the following
    • play - start playback
    • stop - stop playback
    • pause - pause playback
    • prev - go to previous track
    • next - go to next track
    • startofl - go to first track in playlist(winamp only)
    • endofl - go to last track in playlist (winamp only)

    example: %WINAMP_CMD("pause")
  • %SONIQUE("parameter") - returns corresponding information about sonique player.

    parameter can be one of the following
    • path - path of current playing file
    • artist - current playing song's artist name
    • song - current playing song's name
    • length - current playing song's length is m:ss format
    • length_sec - current playing song's length is seconds
    • position - current playing song's position is m:ss format
    • position_sec - current playing song's posistion is seconds

    example: %SONIQUE("path") will return: D:\music\Einsturzende Neubauten\silence.mp3
  • %XMPLAY("parameter") - returns corresponding information from XMPlay player.

    parameter can be one of the following
    • artist - current selected song's artist name
    • title - current selected song's title

    if parameter isn't specified macro will return detailed information about selected song

    example: %XMPLAY("title") , %XMPLAY
  • %MMJB_TITLE - returns current playing song's title from MUSICMATCH Jukebox player.

    returns OFF is player is not running, or STOPPED if player is running but not playing a song.

    example: %MMBJ_TITLE
  • %SETCLIPBOARDTEXT("text") - places the text on clipboard
  • %BEEP(frequency,duration) - generates simple tones on the system speaker(has nothing to to with soundcard).
    frequency specifies the frequency, in hertz, of the sound. This parameter must be in the range 37 through 32767.
    duration specifies the duration, in milliseconds, of the sound.
    note:duration and frequency parameters are used only in windows 2k/xp.
    Windows 9x: On computers with a sound card, the function plays the default sound event. On computers without a sound card, the function plays the standard system beep.
  • %SKIPLINE(text,regular_expression) - removes lines containing regular_expression from text

    example: %SKIPLINE(%QUOTES,">>|wrote:") - will insert quoted text without lines that contain double quotation or "wrote:"

  • %TEXTBEFORE(text,regular_expression,[include]) - returns all lines from text before the line containing regular_expression.
    optional parameter include specifies if line containing regular_expression will be included.If macro is called with 2 parameters it's not included.

    example: %TEXTBEFORE(%QUOTES,"__") , %TEXTBEFORE(%QUOTES,"__",1)

  • %TEXTAFTER(text,regular_expression,[include]) - returns all lines from text after the line containing regular_expression.
    optional parameter include specifies if line containing regular_expression will be included.If macro is called with 2 parameters it's not included.

    example: %TEXTAFTER(%QUOTES,"__") , %TEXTAFTER(%QUOTES,"__",1)

  • %RANDOMFILE(mask) - returns a random file name from directory specified with mask

    example: %RANDOMFILE("c:\windows\*.exe") will return setdebug.exe
  • %VOLUMECONTROL(command,[value]) - controls master volume

    command can be one of the following
    • mute - mutes volume
    • enable - enables volume if it's muted
    • set - sets volume to specified value (1-100)
    value is used only with set command

    example:
    %VOLUMECONTROL("mute")
    %VOLUMECONTROL("set",50)

  • %GETCURRENTVOLUME - returns current volume value (1-100)

  • %EJECTCDROM - opens CD-ROM drive

  • %CLOSECDROM - closes CD-ROM drive

  • %ZVERSION - returns plugin version

back


macros

Список макросов:

  • %PROCSTATUS(имя_процесса) - возвращает ON если процесс запущен, OFF -если нет

    пример: %PROCSTATUS("opera.exe") возвратит ON если Опера запущена
  • %KILLPROC(имя_процесса) - убивает указанный процесс

    пример: %KILLPROC("opera.exe")
  • %FILESIZE(имя_файла,формат) - возвращает размер указанного файла, где формат может принимать следующие значения:

    M - размер в Мегабайтах
    K - размер в Килобайтах
    B - размер в Байтах

    пример: %FILESIZE("c:\windows\explorer.exe","k") возвратит 977
  • %OWNIP - возвращает свой ip адрес, или OFFLINE в случае если Вы не подключены к сети
  • %COPYFILE(откуда, куда,option) - Копирует файл откуда в куда , option указывает как поступать в случае если файл куда уже существует. Если этот параметр равен 1 и файл уже существует то макрос ничего не делает.Если же параметр равен 0 и файл уже существует то он перезаписывается новым файлом.

    пример: %COPYFILE("c:\windows\explorer.exe","c:\explorer.exe","1")
  • %DELETEFILE(имя_файла) - Удаляет файл с именем имя_файла

    пример: %DELETEFILE("c:\temp.txt")
  • %DELETEFILES(маска) - Удаляет все файлы указанные маской

    пример: %DELETEFILES("c:\windows\temp\*.txt")
  • %MD5(строка) - возвращает MD5 хэш строки
  • %WTITLEE(слово) - возвращает заголовок окна заканчивающийся на слово

    пример: %WTITLEE("Explorer") возвратит "about:blank - Microsoft Internet Explorer" (если Internet Explorer открыт с пустой страницей)
  • %WTITLES(слово) - возвращает заголовок окна начинающийся со слова

    пример: %WTITLES("ACDSee") возвратит "ACDSee 6.0 - My Pictures" ( если в ACDSee открыта папка "My Pictures" )
  • %WTITLEALL - возвращает заголовки всех окон (список)
  • %WTITLEREGEXP(regexp) - возвращает заголовок окна удовлетворяющий заданному регулярному выражению regexp

    пример: %WTITLEREGEXP("[0-9]+.*Winamp") возвратит заголовок окна Винампа:
    (такой как "50. Sepultura - Roots, bloody, roots - Winamp" )
  • %INETTIME - интернетовское время в битах(1000 битов=1 день)
  • %NUM_LOCK_ON
    %NUM_LOCK_OFF
    %CAPS_LOCK_ON
    %CAPS_LOCK_OFF
    %SCROLL_LOCK_ON
    %SCROLL_LOCK_OFF

    - включает/выключает индикатор NumLock(CapsLock ,ScrollLock) на клавиатуре
  • %NUMLOCK_IS_ON
    %CAPSLOCK_IS_ON
    %SCROLLLOCK_IS_ON

    - возвращает ON(OFF) если соответствующий индикатор на клавиатуре включен(выключен)
  • %GETINIVALUE(полный_путь_к_файлу,секция,ключ) - возвращает значение соответствующего ключа(key) из соответствующей секции(section) .ini файла

    пример: %GETINIVALUE("c:\boot.ini","boot loader","timeout") возвратит значение ключа timeout из секции [boot loader] файла boot.ini ,например 10
  • %SETINIVALUE(полный_путь_к_файлу,секция,ключ,значение) - устанавливает значение соответствующего ключа key из соответствующей секции .ini файла в value

    пример: %SETINIVALUE("c:\boot.ini","boot loader","timeout","30")
  • %FIGLET(текст,имя_шрифта) - возвращает текст данным figlet(Frank, Ian & Glenn's Letters) шрифтом. имя_шрифта - это имя соответствующего flf-файла из папки fonts.

    пример: %FIGLET("hello","smslant") выведет слово hello следующим шрифтом:
       __       ____
  / /  ___ / / /__
 / _ \/ -_) / / _ \
/_//_/\__/_/_/\___/
    в комплекте имеется 18 figlet шрифтов, дополнительные шрифты можно установить скопировав их в папку fonts.
    Скачать их можно с ftp://ftp.figlet.org/pub/figlet/fonts/(там их болеe 400)
  • %WINAMP_GET("параметр") - возвращает соответствующую информацию из Winamp-а(также Quintessential Player,Apollo).
    Works with     Winamp 2(5),Quintessential Player,Apollo,MediaMonkey. Для работы с плеером iTunes надо скачать дополнительный плагин для iTunes.

    параметр может принимать следующие значения:
    • status - OFF,STOPPED,PLAYING ,PAUSED
    • title - название играющей песни
    • playlist_length - количество песен в playlist-е
    • playlist_pos - номер выбранной песни
    • bitrate - битрейт
    • samplerate - samplerate
    • channels - каналы
    • track_length - длительность песни, в секундах
    • position - позиция играющей песни (в миллисекундах)

    пример: %IF:%WINAMP_GET(status)=PLAYING:"сейчас играет песня номер %WINAMP_GET(playlist_pos) из %WINAMP_GET(playlist_length)":"Winamp выключен"
  • %WINAMP_CMD("command") - Посылает Winamp-у соответствующую команду. Работает с Winamp 2(5),Quintessential Player,Apollo,MediaMonkey.

    command может принимать следующие значения:
    • play - Начать проигрывание
    • stop - Остановить проигрывание
    • pause - Пауза
    • prev - Перейти к следующей песне.
    • next - Перейти к предыдущей песне.
    • startofl - Перейти к первой песне плейлиста.
    • endofl - Перейти к последней песне плейлиста.

    пример: %WINAMP_CMD("pause")
  • %SONIQUE("параметр") - возвращает соответствующую информацию из плеера sonique.

    параметр может принимать следующие значения:
    • path - путь к проигрываемому файлу
    • artist - Имя испoлнителя играющей песни
    • song - Имя играющей песни
    • length - длительность песни, в формате м:сс
    • length_sec - длительность песни, в секундах
    • position - позиция играющей песни в формате м:сс
    • position_sec - позиция играющей песни в секундах

    пример: %SONIQUE("path") выведет D:\music\Einsturzende Neubauten\silence.mp3
  • %XMPLAY("параметр") - возвращает соответствующую информацию из плеера XMPlay.

    параметр может принимать следующие значения:
    • title - Имя играющей песни
    • artist - Имя испoлнителя играющей песни

    если параметр не указан макрос возвращает подробную информацию о текущей песне

    пример: %XMPLAY("artist"), %XMPLAY
  • %MMJB_TITLE - возвращает название играющей песни из плеера MUSICMATCH Jukebox.

    возвращает OFF если плеер не запущен,или STOPPED если запущен но ничего не играет.

    пример: %MMBJ_TITLE
  • %SETCLIPBOARDTEXT("text") - помещает text в буфер обмена
  • %BEEP(частота, длительность) - генерирует простые тоны на системном динамике (не имеет ничего общего со звуковой платой).
    частота определяет частоту звука в герцах. Этот параметр должен быть в диапазоне 37-32767
    длительность определяет продолжительность звука, в миллисекундах.
    примечание:длительность и частота используются только в windows 2k/xp.
    для Windows 9x:На компьютерах со звуковой платой, функция проигрывает системный звук по умолчанию. На компьютерах без звуковой платы - стандартный системный гудок.
  • %SKIPLINE(текст,регулярное_выражение) - - удаляет строки, содержащие регулярное_выражение из текста

    пример: %SKIPLINE(%QUOTES,">>|wrote:") - вставит цитируемый текст без строк, которые содержат двойное цитирование, или "wrote:"

  • %TEXTBEFORE(текст,регулярное_выражение,[include]) - возвращает весь текст до строки в которой встречается регулярное_выражение.
    Опциональный третий параметр include определяет будет ли включена в возвращаемый текст строка содержащая регулярное_выражение. Если макрос вызывается с двумя параметрами то она не включается.
    Если регулярное_выражение не встретилось возвращается текст без изменений.

    пример: %TEXTBEFORE(%QUOTES,"__") , %TEXTBEFORE(%QUOTES,"__",1)

  • %TEXTAFTER(текст,регулярное_выражение,[include]) - возвращает весь текст после строки в которой встречается регулярное_выражение.
    Опциональный третий параметр include определяет будет ли включена в возвращаемый текст строка содержащая регулярное_выражение. Если макрос вызывается с двумя параметрами то она не включается.
    Если регулярное_выражение не встретилось ничего не возвращается.

    пример: %TEXTAFTER(%QUOTES,"__") , %TEXTAFTER(%QUOTES,"__",1)

  • %RANDOMFILE(маска) - возвращает случайное имя файла из директории заданной маской

    пример: %RANDOMFILE("c:\windows\*.exe") выведет setdebug.exe
  • %VOLUMECONTROL(команда,[значение]) - меняет громкость звука

    команда может принимать следующие значения:
    • mute - выключить звук
    • enable - включить звук
    • set - установить громкость на значение(1-100)
    значение используется только с командой set

    пример:
    %VOLUMECONTROL("mute")
    %VOLUMECONTROL("set",50)

  • %GETCURRENTVOLUME - возвращает установленное значение громкости(1-100)

  • %EJECTCDROM -открывает лоток CD-ROM

  • %CLOSECDROM - закрывает лоток CD-ROM

  • %ZVERSION - возвращает номер версии плагина
назад


z0mbie's macros

z0mbie's macros v 0.7

English: [installing] [list of macros]

Russian:[инсталляция] [список макросов]

latest version is available here: http://www.nobat.ru/zombie.php
mirror: http://freenet.am/~zombie/tbp/
comments,suggestions? mailto: zombie@dark.am

thanks to: Yavorsky Vadim for hosting on nobat.ru


installing

Installing the plugin:

  • copy plugin itself(z.tbp) wherever you want.
  • Open TheBat!, go to Options->Preferences->Plug-Ins
  • Click [Add]
  • Select z.tbp
  • Click [Ok]
  • copy "fonts" folder to TheBat! working directory(e.g. C:\Program Files\TheBat!),otherwise %FIGLET macro won't work.
    (this is the default fonts folder location, u can change it by clicking the [Configure] button in Preferences->Plug-Ins window )
back


installing

Инсталляция:

  • Скопировать плагин(z.tbp) куда-нибудь.
  • В Bat-е перейти в Options->Preferences->Plug-Ins
  • Нажать [Add]
  • Выбрать z.tbp
  • Нажать [OK]
  • Cкопировать папку fonts в рабочую директорию TheBat!(к примеру C:\Program Files\TheBat!), в противном случае макрос %FIGLET не будет работать.
    (это путь к папке с шрифтами по умолчанию, его можно поменять нажав кнопку [Configure] в окне Preferences->Plug-Ins)
назад